Members Login
Username 
 
Password 
    Remember Me  
Post Info TOPIC: Serial Gauge Data (tech line)


Newbie

Status: Offline
Posts: 1
Date:
Serial Gauge Data (tech line)


So, I have an ECU on the bench and wanted to play with the gauge data (do some logging, etc).  The tech line is supposed to be the serial data, but when I power up the ECU, I just have a constant pullup to +5V.

I have 12.5V at B+ and gnd on E1.  Same pins I used to clock the data through the AUD.

Do I need something extra to make the serial line for the gauges go active?  I tried a second ECU, just in case I had a dead one, but the same thing.

I put a scope on it, and it's a pretty solid nothing.  Scoping the crystal shows lots of activity so I think the ECU is alive.

Thanks



__________________


Guru

Status: Offline
Posts: 1233
Date:

You can find info about which pins to use here http://ecueditorco.web713.discountasp.net//DIYInterface.aspx

to get engine data from the ecu you have to send an initialization sequence, easiest way to see how its done is to take a look at the code in ecueditor.com https://bitbucket.org/ecueditor/ecueditor/overview


__________________

site_logo_small.png

www.WoolichRacing.comTune your bike to the Limit with our Advanced ECU Flashing Products



Veteran Member

Status: Offline
Posts: 27
Date:

The tech line to the gauges sends only ECT, Gear and Mode in a stream. At least the AIM-Dataloggers says this. I had also tryed to catch them with the k-line from my AIM-EVO4-Logger but it did not work.

If you find out more, please let me know.



__________________
Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.

Tweet this page Post to Digg Post to Del.icio.us


Create your own FREE Forum
Report Abuse
Powered by ActiveBoard