Members Login
Username 
 
Password 
    Remember Me  
Post Info TOPIC: Mitsubishi ECU - Kawasaki KVF 750 -08 V-Twin


Senior Member

Status: Offline
Posts: 350
Date:
Mitsubishi ECU - Kawasaki KVF 750 -08 V-Twin


A friend lend me his "Brute Force" ATV for testing as long as i dont cut up his stock ecu. So will be a while before i will open one up. But will post up some pics and pinouts in meantime to maybe get someone else interested too.

From manual ecu pinout there are 4 "unused" pins. One of them i traced in wiring diagram to get signal when ignition switch is "on". Will check the three remaining when i get to the bike next time. According to pinout there is diagnostic wire and two communication lines. K-Line and Serial lines maybe?

Kawasaki part #: 21175-0137

Mitsubishi ECU #?: F8T99171

Anyone that knows wich mcu inside maybe? Will be some time before i can cut one open...

If anyone wants the pictures or is bigger size email me.



Attachments
__________________


Member

Status: Offline
Posts: 6
Date:

hello, I have a problem with exactly the same ECU, did you open the box or do you have a schematic or datasheet ?

Thanks



__________________


Senior Member

Status: Offline
Posts: 350
Date:

Hi,

Never did get a spare ecu for it so never got one opened.
Are you about to open one or what is the issue with yours?

__________________


Member

Status: Offline
Posts: 6
Date:

the problem is that I have only one ignition that works.
I try the ECU on another quad and it seems to work, I changed the coils and spark plugs, it does not solve the problem.
I thought the crankshaft sensor but there even when the ignition of the first piston that works, I have a doubt on this point.
I looked at the oscilloscope outputs of the ignition and I have no signal on a channel. Maybe you have an idea.



__________________


Senior Member

Status: Offline
Posts: 350
Date:

If Ecu runs good on another bike then it is not the issue.

If coils, sparkplugs and cable between are changed. Check ground, triggering wires from ecu, (loose from connector?)
Do faulty coil build up load? Flywheel, pickup? Wires? Camshaft sensor? Timing? Probably a sensor or wiring harness.
Did only rebuild front diff on that bike so i cannot help you there.

__________________


Member

Status: Offline
Posts: 6
Date:

I did not know there was a camshaft sensor, do you know if the signal arrives at the ECU or another box?
maybe the problem is with the sensor.

Thanks



__________________


Senior Member

Status: Offline
Posts: 350
Date:

Was just guessing, no according to manual. Send me an e-mail if you need it.
Both coils seem to get power from fuel relay, then trigged from one wire each from the ecu.

So either trigger wires are cut in the harness or pins broken in connectors.
Or flywheel trigger points are off/broken.
Do a quick switch of the whole coil package with cable and cap to rule that out, your new coil could be broken?

No fault codes? Maybe ecu has cut bike off from starting for some other unrelated fault.

"The ECU notifies the rider of troubles in DFI system and
ignition system by flashing the FI indicator when DFI system
and ignition system parts are faulty, and initiates fail-safe
function. In case of serious troubles, the ECU stops the
injection/ignition/starter motor operation."


__________________


Member

Status: Offline
Posts: 6
Date:

I check the connector, cables, plugs. Everything seems ok.


I have no error message.


To do more tests, I would like to know what triggers pulses at the input coils? the crankshaft sensor or something ...


Is it possible that if the crankshaft sensor is out of order, there is only one switch that works?



__________________


Senior Member

Status: Offline
Posts: 350
Date:

Ecu calculates the triggering.

Its only one crankshaft sensor, so either one signal for first cylinder and ecu calculates where second should be.
Or flywheel/timing wheel has two timing marks and gives ecu one signal for each. So if you get spark on one cylinder sensor should work.
Fuelpump primes? So that circuit is ok?

When running engine on the starter with plugs out do you get spark on one cylinder each rev?
If only on first turn of the crank that could be another story with ecu putting out one spark but then cuts both for some signal missing.

Other than that if ecu works on other same bike its not faulty.
And if coil packs are tested and working it must be no second signal from triggering wheel, or wiring in between...

Can´t help you more than that without bike in question. Good Luck!

__________________


Veteran Member

Status: Offline
Posts: 54
Date:

The two communications pins will be flash voltage and k line. To communicate by k line you hit the other pin with 16volts :) The k line is password protected and if you change it you can keep other tools  out



__________________

cjsducati@hotmail.co.uk

 



Senior Member

Status: Offline
Posts: 350
Date:

step test wrote:

The two communications pins will be flash voltage and k line. To communicate by k line you hit the other pin with 16volts :) The k line is password protected and if you change it you can keep other tools out


Have you done one of theese? Wich processor do it use?
Do the Kawa´s read/write through K-Line? :)
Piasini hardware and software?



-- Edited by Twice on Thursday 10th of January 2013 08:42:30 AM

__________________


Member

Status: Offline
Posts: 6
Date:

No I have not tested it because I do not have the hardware.
However, I read in the manual that there is a self-diagnosis.

I'll start on this track, I will testing this weekend.



__________________


Member

Status: Offline
Posts: 6
Date:

Hi,
I did some testing this weekend and the fact that I could draw is that the ecu is faulty.
I opened it, but there are a lot of silicone.
If anyone knows how to remove the silicone, I'm interested.
Thanks



Attachments
__________________


Senior Member

Status: Offline
Posts: 130
Date:

step test ha scritto:

I due pin di comunicazione saranno di tensione del flash e k line. Per comunicare con k line colpisci l'altro pin con 16 volt :) La linea k è protetta da password e se la cambi puoi tenere fuori altri strumenti


  hi,

you can have this pinout ?

i have this ATV, i want to read it.

 

thanks in advance



__________________

comatuning@gmail.com

https://www.facebook.com/comatuning/

Page 1 of 1  sorted by
Quick Reply

Please log in to post quick replies.

Tweet this page Post to Digg Post to Del.icio.us


Create your own FREE Forum
Report Abuse
Powered by ActiveBoard