Members Login
Username 
 
Password 
    Remember Me  
Post Info TOPIC: Selenoid control issues?


Veteran Member

Status: Offline
Posts: 95
Date:
Selenoid control issues?


Members,

 

I've been doing some fine tuning and for some reason I'm having trouble with my selenoid control.  I have tried multiple times to adjust the values in the 0% over category for boost control but some of the values won't save. 

 

I've already tried to download the latest software to see if that helps, re-started the computer, and tried saving the values with another map without success. 

 

Any advice here is appreciated.  Thank you, in advance, for your time and effort.

 

Jason



__________________


Guru

Status: Offline
Posts: 1233
Date:

Hi Jason

Is this in the old version of Boost Fuel or the new extended boost fuel?

Cheers
-Justin.

__________________

site_logo_small.png

www.WoolichRacing.comTune your bike to the Limit with our Advanced ECU Flashing Products



Veteran Member

Status: Offline
Posts: 95
Date:

jkwool wrote:

Hi Jason

Is this in the old version of Boost Fuel or the new extended boost fuel?

Cheers
-Justin.


Justin,

This is the legacy version of boostfuel.  I was going to run the extended boosfuel since I'm out re-tuning, but figured it would be best to work the program/software that I'm familiar with.

What do you think I should do sir?



__________________


Veteran Member

Status: Offline
Posts: 95
Date:

Justin,

Also, to clarify this issue a little further, I can enter values in the 0% Over category but when I try to save the new values different values are saved. As an example, in 4th I have 16, 5th I have 19, and 6th I have 19 in the 0% Over category. I've tried to change the 4th gear value to 18 and the 5th and 6th value to 20 without success. For some reason when I try to save these values they change back to 16 in 4th, and 19 in 5th and 6th. It's very strange.

Additionally, just for fun I've tried to open my map in extended boost fuel to see if I can save my 0% Over vales and indeed they work in the extended version.

Lastly, thank you again for your time and effort.

__________________


Guru

Status: Offline
Posts: 1247
Date:

I seem to remember someone else noting that they couldn't save the values. I don't remember who or if/what the resolution was to teh issue though.



__________________


Veteran Member

Status: Offline
Posts: 95
Date:

sportbikeryder wrote:

I seem to remember someone else noting that they couldn't save the values. I don't remember who or if/what the resolution was to teh issue though.


 John,

 

You're right.

 

The post is here:

http://www.suzukihayabusa.org/forum/index.php?topic=158285.0

 

I don't know what this person did to fix the problem.  I've already tried to re-install the program.  I've also tried it on my desktop with another map and the problem remains.

 

Jason



__________________


Guru

Status: Offline
Posts: 546
Date:

tried saving before you close the window ?

__________________


Veteran Member

Status: Offline
Posts: 95
Date:

Maj750 wrote:

tried saving before you close the window ?


 I tried that too without success.



__________________


Guru

Status: Offline
Posts: 1233
Date:

Ok, so its in the original boost fuel module, i am trying to avoid doing too much on ecueditor as i am putting 110% into Woolich Racing Tuned software, but this seems like a bug that needs fixing so i will take a look at it probably tomorrow night ;)

Cheers

-Justin.



__________________

site_logo_small.png

www.WoolichRacing.comTune your bike to the Limit with our Advanced ECU Flashing Products



Veteran Member

Status: Offline
Posts: 95
Date:

jkwool wrote:

Ok, so its in the original boost fuel module, i am trying to avoid doing too much on ecueditor as i am putting 110% into Woolich Racing Tuned software, but this seems like a bug that needs fixing so i will take a look at it probably tomorrow night ;)

Cheers

-Justin.


Justin,

That would be wonderful!  I just got finished tuning on the street with my backpack for three weeks.  I'd hate to have to redo everything I've done thus far with extended boostfuel.

In legacy it will allow me to alter and save 'some' of the values in the 0% Over category, but not the values I'm looking for.  As I mentioned above, 18 in 4th and 20 in 5th and 6th aren't working for me and I've tried with multiple computers and BIN files.

I don't know if it makes a difference (and I don't know if this will work correctly with Google Drive) or not but my BIN is below:

https://docs.google.com/open?id=0B8wYDzlxb_R5cnZYSlFIUmgtR00

https://docs.google.com/open?id=0B8wYDzlxb_R5YWwyXzhGU2RON28

Thank you for everything and Happy New Year.

Jason

 

 



__________________


Veteran Member

Status: Offline
Posts: 95
Date:

jgennaro wrote:
jkwool wrote:

Ok, so its in the original boost fuel module, i am trying to avoid doing too much on ecueditor as i am putting 110% into Woolich Racing Tuned software, but this seems like a bug that needs fixing so i will take a look at it probably tomorrow night ;)

Cheers

-Justin.


Justin,

That would be wonderful!  I just got finished tuning on the street with my backpack for three weeks.  I'd hate to have to redo everything I've done thus far with extended boostfuel.

In legacy it will allow me to alter and save 'some' of the values in the 0% Over category, but not the values I'm looking for.  As I mentioned above, 18 in 4th and 20 in 5th and 6th aren't working for me and I've tried with multiple computers and BIN files.

I don't know if it makes a difference (and I don't know if this will work correctly with Google Drive) or not but my BIN is below:

https://docs.google.com/open?id=0B8wYDzlxb_R5cnZYSlFIUmgtR00

https://docs.google.com/open?id=0B8wYDzlxb_R5YWwyXzhGU2RON28

Thank you for everything and Happy New Year.

Jason

 

 


 More information added here:

http://www.suzukihayabusa.org/forum/index.php?topic=158285.new#new



__________________


Guru

Status: Offline
Posts: 1233
Date:

Ok i think i have found and fixed this issue, what was happening was the psi value entered into the table was being converted to a byte and stored in the bin file, for example when 20psi was being stored it is converted to 190 and stored in the bin file. When this value was pulled back out of the bin file for display it was being converted back to a value of 19.9 psi and this value was being cast to an integer which truncated the value back to 19. I have update the code to round the value instead of truncating it which results in the value of 19.9 being rounded correctly now to 20 which solves the problem :)

At Greg Watter's request, I also implemented a change to the logic when opening the Boost Fuel module from Advanced settings, there is a new dialog box that opens which prompts you with buttons labeled "Extended" or "Legacy". This dialogue only appears for new bin files or bin files which have not previously had the boost fuel moduel enabled. For existing bin files with boost fuel enabled they will open directly into the correct module based on the version of boost fuel being used in the bin file.

I have pushed the release out and it is available now.

Cheers

-Justin.



__________________

site_logo_small.png

www.WoolichRacing.comTune your bike to the Limit with our Advanced ECU Flashing Products



Veteran Member

Status: Offline
Posts: 95
Date:

I just downloaded it and it works!

Thank you very much Justin.

It's raining here in Tampa for the next four days. When the rain stops (and I have a day off) I'll generate some logs to test it. I'll post the results.

Thank you again for everything guys.

__________________


Guru

Status: Offline
Posts: 1233
Date:

No probs mate, good luck with it ;)



__________________

site_logo_small.png

www.WoolichRacing.comTune your bike to the Limit with our Advanced ECU Flashing Products

Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.

Tweet this page Post to Digg Post to Del.icio.us


Create your own FREE Forum
Report Abuse
Powered by ActiveBoard