Members Login
Username 
 
Password 
    Remember Me  
Forum: Suzuki GSX1300R Hayabusa Gen II
Topic Started By Replies Views Rating Last Post
No New Posts Newb question: Are all Gen2 and B King ECMs physically the same.
 
(Preview)
Jon 4 1113
No New Posts Problems with interface connected
 
(Preview)
asanyfuleno 9 1562
No New Posts Wide band o2 sensor
 
(Preview)
ad74710 2 1094
No New Posts ecu editor to woolich software
 
(Preview)
rightgreasy 8 2118
No New Posts A big thankyou to all who've helped to create EE
 
(Preview)
Chipwizard 7 966
No New Posts Gen 2 Busa Bin into K9 GSXR 1000
 
(Preview)
ajpryor 2 933
No New Posts IAP and AP sensor, What are they?
 
(Preview)
ad74710 2 1142
No New Posts bin files for busa genII ?
 
(Preview)
ad74710 8 1493
No New Posts nos for gsxr 1000
 
(Preview)
wayne 12 983
No New Posts Alternate boost control strategies
 
(Preview)
sportbikeryder 5 1339
No New Posts Crazy Idea...
 
(Preview)
NorthTitan33 1 797
No New Posts Oscilloscope Insulation Piercing Probes
 
(Preview)
Yallgotboost 3 776
No New Posts 2 step fueling
 
(Preview)
JOettel325 5 965
No New Posts 2-Step always on on a GEN2 dragbike application
 
(Preview)
sportbikeryder 3 966
No New Posts New software feature requests
 
(Preview)
sportbikeryder 0 676
No New Posts GEN2 1475 Need injector balance?
 
(Preview)
8secbusa 4 1152
No New Posts What is the minimal amount of sensors needed for spark?
 
(Preview)
Yallgotboost 7 947
No New Posts AVGAS & LC-1
 
(Preview)
Hagarr 2 818
No New Posts Thanks Marlin, Petri, Justin, Sami and other contributers
 
(Preview)
Maj750 8 1245
No New Posts NOS Function.. Timing retard issue
 
(Preview)
8secbusa 5 1099
No New Posts Woolich Racing Tuned Software
 
(Preview)
jkwool 29 5518
No New Posts is there a shift light function when using nos
 
(Preview)
rightgreasy 2 741
No New Posts What fuel and ignition map does the nitrous switch to Gen 2 Busa?
 
(Preview)
Diyms 1 733
No New Posts Ecu log box keep corrupting files
 
(Preview)
rightgreasy 22 2109
No New Posts Datalog problem
 
(Preview)
NorthTitan33 22 1799
No New Posts STP MS0 ONLY 80% TPS
 
(Preview)
LenTurbo 9 1479
No New Posts Cooling fan issue
 
(Preview)
srs 3 1317
No New Posts can't get engine data to work
 
(Preview)
badass1000 4 1213
No New Posts Workings of ECU boost control?
 
(Preview)
Turboy750 5 1934
No New Posts 32920-23H30 bin file for 78KW restricted B-King
 
(Preview)
Blackgixxer 5 1674
«First  <  1 2 3 4 5 614  >  Last»  | Page of 14  sorted by
Forum Statistics
Registered Members: 3,073   Topics: 2,301   Total Posts: 21,707
There are currently 0 member(s) and 11 guest(s) online.
285 user(s) visited this forum in the past 24 hours
The most users ever online at once was 18 member(s) and 163 guest(s) at 12:14pm Sep 07, 2010
Forum Information
Total Posts: 8428
No New Posts New Posts
Topic is Closed Sticky
Tweet this page Post to Digg Post to Del.icio.us


Create your own FREE Forum
Report Abuse
Powered by ActiveBoard