Members Login
Username 
 
Password 
    Remember Me  
Post Info TOPIC: RomRaider interface ( scheme and wiring diagram ) '


Veteran Member

Status: Offline
Posts: 30
Date:
RomRaider interface ( scheme and wiring diagram ) '


Help
Do you need to RomRaider special interface or you can use the same ECU as the editor?

(If everything is the same as an editor for the ECU, then it is all clear)

thank you



__________________


Senior Member

Status: Offline
Posts: 180
Date:

Hello
Do you mean to flash?
Yes, I use the same as for the Ecueditor.



__________________

http://motorsport-brix.de/



Veteran Member

Status: Offline
Posts: 30
Date:

Yes

Unfortunately I can not establish communication with the ECU, the ECU using the editor (appears: error boot failed)
Everything I checked, wiring, software, ... but no go
I tried using RomRaider, it may be more luck

thank you



-- Edited by Gixer on Thursday 15th of March 2012 02:25:16 PM

__________________


Senior Member

Status: Offline
Posts: 180
Date:

You have to start.
Switch interface.
And then ECU Power.smile



__________________

http://motorsport-brix.de/



Veteran Member

Status: Offline
Posts: 30
Date:

I tried it, but no results.

 gauge does not work or the editor.



__________________


Senior Member

Status: Offline
Posts: 180
Date:

What do you want to do flash or Sign?
which model?



__________________

http://motorsport-brix.de/



Veteran Member

Status: Offline
Posts: 30
Date:

Ecu is from Hayabusa 2004. ( 23920-24FKO ).

__________________


Senior Member

Status: Offline
Posts: 180
Date:

Edit the file with Romraider.
Flash file with the FDT.

Or with Ecueditor-Edit.



-- Edited by Brix on Thursday 15th of March 2012 04:10:35 PM

__________________

http://motorsport-brix.de/



Veteran Member

Status: Offline
Posts: 30
Date:


Thanks.
What is the process of transferring bin files in xml?
I found some instructions, but my English is bad, so I did not really understand the process?
Is there somewhere explained the entire process?
Thank you very much

__________________


Veteran Member

Status: Offline
Posts: 30
Date:

Is there a possibility that TTL - RS232 - 5V converter is wrong because it can not establish communication with the ECU?
Although I have tested it using the analyzer and this is all ok.

__________________


Senior Member

Status: Offline
Posts: 180
Date:

Only connect or turn on the interface.
Only then ECU 12V.



__________________

http://motorsport-brix.de/



Veteran Member

Status: Offline
Posts: 30
Date:

I tried all last night, but no results. Obviously something else is wrong. Thank you very much for your patience



__________________


Senior Member

Status: Offline
Posts: 180
Date:

Normaly it is very simpel.

Conect the Interface to the ECU -look at the Pin-out at Forum.

For the FLASH you need FDT 4.00 or higher-

READ the Instruction of Hayabusa Gen1

YOU find all .



__________________

http://motorsport-brix.de/



Veteran Member

Status: Offline
Posts: 30
Date:

Do not go, I made the interface according to the scheme (), (I use TTL - RS 232 - 5V).
ECU installed editor, all made according to the instructions, but there is no connection, gauge the laptop is not working.
Obviously I'm stupid for it
I use FDT 4:01
Which driver to use to use the TTL - RS232 - 5V?
thank you



-- Edited by Gixer on Monday 2nd of April 2012 05:16:22 PM

__________________


Senior Member

Status: Offline
Posts: 350
Date:

You can install drivers via EcuEditor in the menu. TX/RX shall be switched. Common grounds.
Else you probably built interface wrong. But for flashing you only need the USB TTL232R cable.
Rest is just for livedata...

__________________


Veteran Member

Status: Offline
Posts: 30
Date:

Thank you.
Thank you.
According to the scheme, RX, TX, ground and 5 V are directly connected (ECU and TTL RS232), it's hard to go wrong here.
At least you should do read the data.

Theoretically, if the ECU directly to TTL RS232 connect RX, TX, 5V and ground, the data should be read in ECU editor?


To at least get to that stage, then he knew that connection is working properly. .



-- Edited by Gixer on Tuesday 3rd of April 2012 08:18:56 AM

__________________


Senior Member

Status: Offline
Posts: 350
Date:

Did you forget ground? I always joint all grounds, including cable and power supply

Rx from ECU goes to Tx in cable and vice verse. (Try switching them, no harm will be done)
+5V is only to put box in bootloader, and gnd for reset. But i have only flashed gixxers.

In this link you got some extra pins connected and one etra switch, in the schematic for you busa.
Try the above and then this link:

http://ecuhacking.activeboard.com/t14963483/instructions-how-to-use-fdt-for-flashing-the-ecu-2004-2007/forum.spark?forumID=99460&p=3&topicID=14784871

Also, some have had problems if its not a genuine FTDI TTL 232R cable. Also i am running FDT 4.7 (4.8) is out also i think. And here is link for use of FDT. Remember that you cannot read your stock file this way, when connected FDT first thing it will do is to erase the ecu.

http://ecuhacking.activeboard.com/t14963483/instructions-how-to-use-fdt-for-flashing-the-ecu-2004-2007/

Throw up some photos of your connection ECU - FTDI Cable also. (High Res)

If none of this gets you to flash the ecu then you probably will be better off sending someone the ECU to do it for you... 



__________________


Veteran Member

Status: Offline
Posts: 30
Date:

Thank you very much for your patience and help.

Now I am currently at work so when I get home, I'll make a photo.
I made ground, as you said, I changed pokupavao RX and TX, ....

This information may help.
Every time I start the ECU editor, I have to install a COM port device driver every time the message "reboot your computer now."
Is this normal?



-- Edited by Gixer on Tuesday 3rd of April 2012 09:49:22 AM

__________________


Senior Member

Status: Offline
Posts: 350
Date:

I have never actually flashed through EcuEditor since its currently not supports models i flashed so far, only live data.
Have you tried to flash through Renesas FDT software only? FDT has always worked like a charm for me :)

__________________


Veteran Member

Status: Offline
Posts: 30
Date:

Hi,
Just trying to re-download the ecu editor and FTD.
I will try with 4:00 version, until now I had 4:01
Can you please put all the links to software that you took off?
So I'll be sure it all works
thank you

__________________


Senior Member

Status: Offline
Posts: 350
Date:

I just download FDT from renesas homepage: http://www.renesas.eu/products/tools/flash_prom_programming/fdt/downloads.jsp
Try some of the newer versions 4.07 or 4.08. Else try on a different computer also, might be some other driver issues...

__________________


Guru

Status: Offline
Posts: 1247
Date:

Is this ECU on the bike or are you flashing off of the bike?

If off of the bike, is the ECU powered with +12v?



-- Edited by sportbikeryder on Friday 6th of April 2012 07:23:34 PM

__________________


Veteran Member

Status: Offline
Posts: 30
Date:

Everything I do, I work on bikes
Thanks guys
So far I've got a gauge that works (I did not connect pin 33 ).
But Flash still does not work, I installed FDT, reinstall the ECU editor, but it does not work, there is Error No.: 15024 boot failed

__________________


Veteran Member

Status: Offline
Posts: 30
Date:

Guys, many many thanks for your efforts and patience

Finally everything works
I made mistakes all the time in the order of turning the key on the bike and switch to the interface.

Thanks again

__________________


Guru

Status: Offline
Posts: 1247
Date:

Glad you got it figured out.

__________________


Veteran Member

Status: Offline
Posts: 30
Date:

Thank you.

How do you know that the flasher successfully. I tried rpm limiter set at 4000 RPM,but the ECU editor does not allow such low RPM?



-- Edited by Gixer on Wednesday 11th of April 2012 09:12:08 PM

__________________
Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.

Tweet this page Post to Digg Post to Del.icio.us


Create your own FREE Forum
Report Abuse
Powered by ActiveBoard