Members Login
Username 
 
Password 
    Remember Me  
Post Info TOPIC: GSXR 1000 K9 Interface?


Member

Status: Offline
Posts: 10
Date:
GSXR 1000 K9 Interface?


Hello,

where can i find a layout for a K9 USB Interface so that i can use the ECU-Editor?

Searched for it in the forum, couldnt find it yet.

 

Kind regards,
nordx



__________________


Veteran Member

Status: Offline
Posts: 30
Date:

interface.jpgEE2 CONNECTOR WIRING GSXR1000  K7-11.png



Attachments
__________________


Member

Status: Offline
Posts: 10
Date:

thanks for the fast reply!

__________________


Member

Status: Offline
Posts: 10
Date:

Hello,
I have to take the 5V signaling ftdi chip, right?
I accidently bought the 3,3V signaling cable :(... I bet that would not work with this ecu, right?

__________________


Guru

Status: Offline
Posts: 964
Date:

No the 3.3V will not work.

__________________


Member

Status: Offline
Posts: 12
Date:

I am sorry for the question, but will this work with Woolich software? also is this the right type of cable? Thank you in advance for any help.  

http://www.amazon.com/GearMo%C2%AE-Header-Like-FTDI-TTL-232R-5V/dp/B004LC28G2

 



__________________


Member

Status: Offline
Posts: 12
Date:

Can some one also provide a part # for the switch please?



__________________


Member

Status: Offline
Posts: 10
Date:

i tried to connect with the ECU Editor to my ECU, doesnt work :(...

I setup up my comport (i reedited it to COM2 because it denied COM13 - got message "out of range.." or something) and than nothing happens... How can i connect to the ECU? DO i have to press a button or something, or will it normaly connect automatically?

Did i do it right:

RTS (Green Cable) with Pin 17
GND (Black cable) with Pin 35
RXD (Yellow Cable) with Pin 15
TXD (Orange Cable) with Pin 16
+5V (Red Cable) in series with a 1k Ohm resistor with Pin 29

Whats up with the FWE Pin? what should i connect there?

I didnt connect the Brown cable,...

Can someone tell me how the correct connection should be?

ECU still works, tested it ^^...

Ah, and i connected the +12V (with Pin 12) and GND (with Pin 36) with the Batterie

ECU-Connecting.jpg

-- Edited by nordx on Tuesday 8th of April 2014 07:37:30 PM



-- Edited by nordx on Tuesday 8th of April 2014 07:38:00 PM

Attachments
__________________


Member

Status: Offline
Posts: 12
Date:

nordx wrote:

i tried to connect with the ECU Editor to my ECU, doesnt work :(...

I setup up my comport (i reedited it to COM2 because it denied COM13 - got message "out of range.." or something) and than nothing happens... How can i connect to the ECU? DO i have to press a button or something, or will it normaly connect automatically?

Did i do it right:

RTS (Green Cable) with Pin 17
GND (Black cable) with Pin 35
RXD (Yellow Cable) with Pin 15
TXD (Orange Cable) with Pin 16
+5V (Red Cable) in series with a 1k Ohm resistor with Pin 29

Whats up with the FWE Pin? what should i connect there?

I didnt connect the Brown cable,...

Can someone tell me how the correct connection should be?

ECU still works, tested it ^^...

Ah, and i connected the +12V (with Pin 12) and GND (with Pin 36) with the Batterie

ECU-Connecting.jpg

-- Edited by nordx on Tuesday 8th of April 2014 07:37:30 PM



-- Edited by nordx on Tuesday 8th of April 2014 07:38:00 PM

 

 

nordx,  did you build this device? If so can you help me out a bit please? I would like to build this also i just need a few part #s and maybe a pic or two of the device. Thank you ahead of time.

 

 



__________________


Member

Status: Offline
Posts: 10
Date:

if it would work, i would post some more information, at the moment, i cant connect to the ECU with ECU Editor, i dont know why... little advice of people who allready did that would be really nice.

__________________


Member

Status: Offline
Posts: 12
Date:

nordx wrote:

if it would work, i would post some more information, at the moment, i cant connect to the ECU with ECU Editor, i dont know why... little advice of people who allready did that would be really nice.


 

 

I just bought the parts and figured out what toggle to use. As soon as I get the order I will try it and update this thread. 

 



__________________


Member

Status: Offline
Posts: 12
Date:

I just posted a request to tipi65 asking for help.


__________________


Member

Status: Offline
Posts: 10
Date:

no ideas anyone? how the people did that 2-3 years ago...

__________________


Member

Status: Offline
Posts: 12
Date:

I just got the parts and am going to attempt to build the unit. I will update you with my progress.


__________________


Member

Status: Offline
Posts: 10
Date:

ok, good luck, i hope you get it!

__________________


Guru

Status: Offline
Posts: 964
Date:

Why does your power supply show 0.0 amps current draw? If the ecu is connected correctly it should show 0.1-0.2 amps.



__________________


Member

Status: Offline
Posts: 10
Date:

maybe its not the best sensitivity, it sometimes jumps to 0,1A - i could measure it.


What i did yesterday: i connected the brown cable directly to +5V like in the picture... and testet again... But i dont know if its working correct, i changed the rpm limit to 10.000 and flashed it. No error was showing up... i will test it today if it worked.

If so i will make a a little summary and post it here.

__________________


Member

Status: Offline
Posts: 12
Date:

I finished building the interface yesterday. I will test today. I hope it works.


__________________


Member

Status: Offline
Posts: 12
Date:

Can any one tell me were the K-Line gets connected to?


__________________


Member

Status: Offline
Posts: 12
Date:

I found a doc that has the pin out.

docs.google.com/spreadsheet/ccc

there are tabs at the bottom.

I tried the interface but it did not work.

I will try it again after I go back threw my interface.

__________________


Member

Status: Offline
Posts: 19
Date:

i have the same problem.

I build a simple pcb interface with switch and it can't work. If i try to connect direct wire idem.

i don't know why.

I use ttl 5v wire cable.

__________________


Member

Status: Offline
Posts: 12
Date:

This design does not work. I have tested it in every way possible.


__________________


Senior Member

Status: Offline
Posts: 137
Date:

This design works perfect...tested hundred times..
Never had problem with it and software..

__________________


Veteran Member

Status: Offline
Posts: 30
Date:

Jotkut halvat  klooni FTDI kaapelit eivät toimi kanssa uusia ajureita.

Kuljettaja toimii klooni kaapelit

 

CDMUninstaller_v1.4

http://yadi.sk/d/WhctyrNxSmh26

 

CDM_2.08.24_WHQL_Certified

http://yadi.sk/d/-UckxKIQSmisJ

 



-- Edited by tipi65 on Monday 9th of June 2014 08:59:01 AM

__________________


Member

Status: Offline
Posts: 12
Date:

BUZKA wrote:

This design works perfect...tested hundred times..
Never had problem with it and software..


 Can you give me some guidance on this issue. Hear is how I have it connected: 

 SDS  
1B/WPIN 36 -12 Ground12 Volt -
2GRAYPIN 62 (KLINE)K-Line
3   
4W/RPIN 70 
5   
6O/GPIN 12 (PWR SOURCE)12 Volt +
    
 YOSHI CONNECTOR  
1Added cablePin 17 ResetReset
2RPIN 7 (VCC) 
3BLUE/YELLOWPIN 15 TXDTXD
4Added cablePin 29 FEWFEW 
5BLUE/GREENPIN 16 RXDRXD
6BL/BPIN 51 
7BL/WPIN 52 
8B/BRPIN 35 Ground Sensor Flasher 


__________________


Member

Status: Offline
Posts: 12
Date:

I ordered the FTDI cable from Digi-Key. Here is the order I placed. 

 

14400BC547CZL1GOSCT-NDBC547CZL1GBC547 NPN0.39000$1.56
210100010.0KXBK-NDMFR-25FBF52-10KRES 10K OHM0.08200$0.82
322001KADCT-NDMFP-25BRD52-1KRES 1K OHM0.55000$1.10
411001003P1T2B1M1QE-ND1003P1T2B1M1QE3 POLE ON ON5.08000$5.08
51100281-1148-ND1614250000HEADER3.11000$3.11
61100768-1028-NDTTL-232R-5VUSB ADAPTER20.00000$20.00
71100438-1103-NDB10-8000-PCBPLATED PROTO BRD11.54000$11.54
81100438-1090-NDB10-8000BOX15.93000$15.93


__________________


Senior Member

Status: Offline
Posts: 137
Date:

You dont need any PCB to make it work.
Just buy damaged harness to extract cconnector and you can connect cable directly to ECU


__________________
Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.

Tweet this page Post to Digg Post to Del.icio.us


Create your own FREE Forum
Report Abuse
Powered by ActiveBoard